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About hp OpenView storage area manager
HP OpenView Storage Area Manager provides comprehensive, centralized 
management across distributed, heterogeneous storage networks. The Storage 
Area Manager product suite includes the following five applications: Storage 
Node Manager, Storage Optimizer, Storage Builder, Storage Accountant, and 
Storage Allocater.

These applications work within a framework that is available regardless of which 
applications are installed and licensed. Among other features, this framework 
provides:

Device discovery and mapping
Storage Area Manager automatically discovers hosts, interconnect devices, and 
storage devices in direct attached (Fibre Channel or SCSI) and networked storage 
(SAN and NAS) environments. Discovered devices are placed in the Resources 
tree and a device map. Storage Area Manager illustrates the relationship of these 
devices by displaying their links within each device map.

If the storage network is using interconnect hardware to support fabric zoning, 
Storage Area Manager identifies the pre-configured zones and lists them under the 
Storage Networks node in the Resources tree. Storage Area Manager also creates 
a corresponding device map of each zone.

Event management
Based on its status inquiries of the storage network and its own processes, Storage 
Area Manager generates and displays events in the event panel. Framework and 
discovery-related events are displayed regardless of which applications are 
installed and licensed. Device status, performance, capacity, billing, and LUN 
security related events only appear if the applicable application is installed and 
licensed.
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Storage Area Manager is able to receive SNMP traps from devices that support 
trap forwarding. You can also configure event triggers to perform certain actions 
based on event criteria. For example you can configure an event trigger to send 
e-mail notification to your on-call administrator for all events of a particular 
severity level.

Storage Area Manager also provides several features to manage the events that 
appear in the event panel. You can configure filters so only events that meet the 
filter’s criteria are displayed in the event panel. You can also export all or selected 
events to a .txt, .csv, or .xml file. Finally, you can configure Storage Area Manager 
to automatically delete events based on a maximum number or on certain criteria 
such as event age, event severity level, or event category.

Manager of Managers
The Manager of Managers (MoM) enables you to monitor several storage 
domains from one console. You can configure MoM to retrieve and display status 
and event information from each Storage Area Manager management server in 
your environment. This feature allows Storage Area Manager to easily scale in 
large, complex storage environments.

User authentication and authorization
When starting Storage Area Manager, users must login with their unique user 
name and password. Storage Area Manager user accounts can be configured with 
different levels of privilege. User accounts with Administrator privilege are able to 
save changes to the Storage Area Manager database and may perform all Storage 
Area Manager tasks. User accounts with Guest privilege are only able to view 
information provided by Storage Area Manager and are not able to save changes. 
User account privileges apply to tasks conducted both through the graphical user 
interface (GUI) and command line user interface (CLUI).
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Storage Node Manager
Storage Node Manager provides device status monitoring and reporting capability 
to the Storage Area Manager product suite. Among other features, Storage Node 
Manager provides:

Device status monitoring

Storage Node Manager monitors and graphically displays the status of each 
discovered device in your storage network. Device status is displayed wherever 
the device is referenced in the user interface, including the Resources tree, device 
map, and event panel.

Based on its status inquiries of the storage network, Storage Area Manager 
generates and displays status-related events as they occur in your storage network.

Application linking

You can link device-specific applications to Storage Area Manager and then start 
them from the user interface. The applications are linked to specific devices or 
device models. Many default device-specific application links are provided with 
Storage Node Manager.

Storage Optimizer
Storage Optimizer monitors and reports device performance in a storage network. 
Performance metrics vary by device; however, a set of common metrics are 
available for all devices supported by Storage Optimizer. Among other features, 
Storage Optimizer provides:

Performance views

Performance views for host disks, volumes, interconnect devices, ports, storage 
devices, and LUNs. Performance lists, displayed for groups of devices in the 
Resources tree, allow you to compare common metrics for all disks, volumes, 
storage devices, and so on. Performance charts show you the performance analysis 
of individual devices over time.
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Top-N analysis

You can sort performance lists by order of performance and limit the length of the 
list to the first 5, 10, 15, and so on to 100 devices.

Past and future trends

Performance charts display a line graph of past and future performance. Storage 
Optimizer predicts future performance by identifying trends in past data. You can 
turn this feature on or off, and you can select from a full range of predictive 
models.

Performance thresholds and threshold events

Storage Optimizer monitors the current and predicted performance of individual 
resources for threshold violations. If performance differs significantly from a 
mathematically derived baseline, Storage Optimizer sends a threshold violation to 
Storage Area Manager’s event panel. Administrators can turn baselines on or off 
and configure event triggers.

Data export

You can save the contents of performance charts in a comma-delimited (.csv) file.

Storage Builder
Storage Builder monitors and reports storage capacity in a storage network. It 
routinely discovers the physical capacity of storage devices and logical capacity of 
hosts and NAS devices, and analyzes the information for current usage, past and 
future usage trends, and threshold violations. Among other features, Storage 
Builder provides:

Capacity data for host resources

Host resources include directories, disks, users, volumes, and volume groups. 
Clicking any of these labels in the Resources tree displays a list of the individual 
resources and their capacities. Selecting a resource from the list displays 
additional information about the individual directory, disk, user, and so on.
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Capacity views

For hosts and NAS devices, view panels show the used and free file space. For 
storage devices, the view panels show the disk space that is visible to hosts, that is 
unformatted, and that is spent in overhead. At the group level in the Resources 
tree--the domain Hosts, NAS Devices, and Storage Devices nodes--Capacity view 
panels display summarized capacity information for the corresponding resources.

Past and future usage trends

From the Capacity view panel, you can display a line graph of past and future 
capacity. Storage Builder predicts future capacity by identifying trends in past 
data. You can turn this feature on or off, and you can select from a full range of 
predictive models.

Capacity thresholds and threshold events

Storage Builder monitors the current and predicted capacity of individual 
resources for threshold violations. If measured capacity exceeds or falls below a 
specified target, Storage Builder sends a threshold violation to Storage Area 
Manager’s event panel. Administrators can set thresholds and configure event 
triggers.

Data export

You can save the contents of capacity graphs and pie charts in a comma-delimited 
(.csv) file.

File Analysis

You can generate a report on stale files, junk files, the largest files, largest 
directories, and all files and directories on each and all hosts in the domain. You 
can modify the default reports and create original reports.



Introduction

11Storage Area Manager Service Desk Integration administrator’s reference

Storage Accountant
Storage Accountant meters storage space in organization accounts and reports the 
associated cost at the end of each month. Accounts belong to internal or external 
organizations. Among other features, Storage Accountant provides:

Service Level, Organization and Account nodes in the Applications tree

Storage Accountant associates LUNs with service levels and then associates the 
service-rated LUNs with organization accounts. You can view, create, add LUNs 
to, and maintain service levels and organization accounts from these nodes.

Centralized setup functions

The Accounting view panel provides all the tools you need to set up storage 
billing. You can view, create, and add LUNs to service levels; view and create 
organizations; add organization accounts; and attach LUNs to accounts. You can 
also view the total number of service levels, organizations, LUNs in service levels, 
and the total storage value that is billed and not billed.

Monthly and interim bill reports

Storage Accountant rolls up daily charges into a monthly bill that is arranged by 
organization and account. Detailed bills describe the charges for each LUN. 
Summary bills show only the total charges for each organization and account. 
Using the Bill Viewer, you can view, export, and print bills for the current 
(interim) or past billing periods and for all or individual organizations.

Storage device and service level billing reports

Storage Accountant creates monthly billing reports that are organized by storage 
device or service level. Summary reports show the total charges for the storage 
device or service level LUNs in accounts and LUNs not in accounts. Detailed 
reports show summary information and a LUN-by-LUN description of charges.



Introduction

12 Storage Area Manager Service Desk Integration administrator’s reference

Exported bills

Storage Accountant automatically exports monthly bill reports in a format and 
location that you choose. Available formats include CSV, HTML, and XML. You 
can set event triggers that launch a third-party billing application once the report is 
exported.

Storage Allocater
Storage Allocater controls storage access and provides security by assigning 
logical units (LUNs) to specific hosts or groups. Assigned LUNs cannot be 
accessed by any other hosts. With this application, you can assign, unassign, and 
reassign storage and related devices from a diverse pool. Among other features, 
Storage Allocater provides:

Security Groups

Share groups and associated LUN groups streamline your storage assignments. 
Share groups allow multiple hosts to share the same storage devices. Associated 
LUN groups keep sets of logical units (for example, stripe sets or mirror sets) 
together, requiring them to be assigned and unassigned as a unit.

Organizational Groups

Host groups and LUN groups allow you to arrange hosts and logical units into 
hierarchical groups in the Storage Area Manager user interface.

Reports

Storage Allocater can generate reports that show all LUNs, assigned LUNs, or 
unassigned LUNs. These reports allow you to quickly view the assignment status 
of all of the LUNs in the current storage domain.
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System availability

Storage Allocater provides increased system availability by enabling storage to be 
assigned, unassigned, and re-assigned without reboots.

Automation of LUN allocation operations

Hooks in the Storage Area Manager command-line interface allow you to 
automate LUN allocation operations with scripts.
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hp OpenView storage area manager architecture
Storage Area Manager’s hardware and software architecture consists of the 
bridge, management server, managed host(s), management client(s), and the 
Manager of Managers (optional). This section offers an overview of each of these 
elements.

Figure 1:  hp OpenView storage area manager Architecture
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Bridge
The Storage Area Manager bridge is a web server application that allows other 
applications access to Storage Area Manager’s functionality. This access enables 
Storage Area Manager to have tight integration with other hp OpenView 
enterprise applications. The bridge is able to consolidate information from 
multiple management servers for use by the application integrating with the 
bridge.

The bridge is automatically installed on the management server when you install 
Storage Area Manager from the CD.

Management Server
The management server is a server application that hosts the majority of Storage 
Area Manager functionality. This framework includes Storage Area Manager’s 
database, discovery subsystem, event handling subsystem, configuration files, and 
server components for each of the five applications that comprise the product 
suite.

The management server software is installed from the Storage Area Manager CD 
on a dedicated Windows 2000 server or workstation. One management server 
manages a single storage domain. A storage domain consists of storage resources 
that are visible to the SAN hosts associated with the management server. Storage 
Area Manager is capable of managing direct-attached, SAN-attached, or 
network-attached storage resources.

Managed Host
The managed host contains the host agent software, which includes all 
components that require access to the storage resources that are visible to the 
hosts. These components include discovery, status and event inquiry, and 
performance and capacity data collection.
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The host agent software can be installed remotely from the management server or 
locally from the Storage Area Manager CD on to a Windows, HP-UX, Solaris, 
Linux, AIX, Tru64 Unix, OpenVMS, and Netware hosts. Upon successful 
installation, the host becomes associated with and dedicated to the management 
server. The host agent runs as a service on Windows hosts and as a daemon on 
Unix hosts.

Management Client
The management client is a graphical user interface (GUI) application that uses a 
common navigation and presentation framework to display the storage 
information that is stored by the management server.

The management client software is automatically installed on the management 
server. The management client can also be downloaded from the management 
server to remote client systems running Windows, HP-UX, Solaris, or Linux.

Manager of Managers
The Manager of Managers (MoM) is a graphical user interface (GUI) application 
that consolidates storage information from multiple storage domains. This allows 
an administrator to view from a single location the high-level status and filtered 
event information of a large or geographically dispersed storage network. The 
administrator can also launch the management client for a particular storage 
domain to view the detailed information displayed by the client.

The MoM software can be downloaded from the management server to remote 
Windows, HP-UX, Solaris, and Linux hosts. It is an optional piece of the Storage 
Area Manager architecture.
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OpenView Enterprise Applications
Storage Area Manager integrates with various OpenView enterprise applications. 
Through the bridge, the Storage Area Manager SMART Plug-In (SPI), and the 
integration packages contained on the Storage Area Manager CD, Storage Area 
Manager information and control can be integrated with:

■ hp OpenView Reporter (OVR)

■ hp OpenView Service Information Portal (SIP)

■ hp OpenView Operations for Windows (OVW)

■ hp OpenView Operations for Unix (OVO)

■ hp OpenView Internet Usage Manager (IUM)

■ hp OpenView Service Navigator

■ hp OpenView Service Activator

■ hp OpenView Service Desk
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hp OpenView storage area manager user interfaces
Storage Area Manager provides two interfaces within which you can perform 
storage management tasks: the graphical user interface (GUI) and the command 
line user interface (CLUI).

Graphical User Interface
Storage Area Manager’s intuitive, tri-pane GUI allows you to monitor the status of 
your storage network, view event information, and easily perform administrative 
tasks. Figure 2 illustrates some of the key elements of the Storage Area Manager 
GUI.

Figure 2:  hp OpenView storage area manager GUI

Title bar

The title bar indicates the node or subnode currently selected in the tree panel and 
the product name. For example, “DEFAULT_DOMAIN - hp OpenView storage 
area manager”.
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Menu bar and toolbar

The menu bar and toolbar provide access to commonly performed tasks. 
Application icons are included on the toolbar, which provide direct navigation to 
each application’s home page.

Tree panel

The tree panel includes two views, Resources and Applications, which are 
controlled by the Tree panel tabs at the bottom of the tree panel.

■ The Resources tree lists resources managed by the storage domain including 
storage networks, devices, and organizations. Storage networks are defined as 
islands of Fibre Channel connectivity, which indicates that each device in the 
storage network is able to send Fibre Channel commands to all other devices 
in the storage network. Each storage network is represented by a 
corresponding device map.

Device types include hosts, interconnect devices, bridges, storage devices, 
NAS devices, and unknown devices.

Organizations include various resources in their membership and are used by 
Storage Accountant as part of its billing functionality.

■ The Applications tree includes a node for each of the five applications that 
make up the Storage Area Manager product suite. Each application node 
includes shortcut navigation to that application’s primary tasks.

Event panel

The event panel lists events received and reported by Storage Area Manager as it 
monitors the storage network. Each event listed in the event panel includes its 
severity level, the date and time it occurred, the source of the event, the event’s 
category and type, and the message provided by the event itself.

The Storage Area Manager’s event management subsystem enables several 
features to help you manage the events displayed in the event panel. These 
features are conducted through use of the toolbar icons near the top of the event 
panel and include such tasks as acknowledging, deleting, and exporting events. 
You can also create event filters, which enable you to display only those events 
that meet the criteria you set when creating the event filter.
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View panel

The view panel displays detailed content for the node or subnode that is currently 
selected in the tree panel.

This may include lists (for example, a list of all storage devices), specific device 
properties information (for example, identifying information for a particular disk 
array), device capacity or performance data (for example, the amount of 
unconfigured space for a particular disk array), or device maps that illustrate the 
storage network.

Tabs near the top of the view panel provide navigation to other areas of content for 
the displayed device.

Application indicator

The application indicator reflects which application’s information is currently 
displayed in the view panel.

Discovery indicator

The discovery indicator reflects if Storage Area Manager’s ongoing device 
discovery process is on or off.

Command Line User Interface
Storage Area Manager’s CLUI provides an alternative interface to the GUI. 
Nearly all tasks that can be performed in the GUI can also be performed from the 
CLUI.

Like the GUI, the tasks that can be performed within the CLUI are restricted by 
the Storage Area Manager applications that are installed and licensed and by the 
privileges assigned to the user name that is used to log into the CLUI.
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The CLUI offers several forms of assistance for each command including purpose 
statements, help text, and man pages.

■ Purpose statements offer a high-level description of the command. To view 
the purpose statement for a particular command, enter:

purpose <“command name”>

Note:  You must include the command name in quotes (“”) when running the purpose 
command. This is not required for the help text or man page commands.

■ Help text offers detailed usage information for each of the command’s options 
and arguments. To view the help text for a particular command, enter:

help <command name>

■ Man pages are the highest level of assistance for each command. Each man 
page includes an expanded description of the command, its options and 
arguments, the license and user account privilege required to run the 
command, an example, and a list of other CLUI commands that are closely 
related to this command. To view the man page for a particular command, 
enter:

man <command name>
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What is hp OpenView storage area manager Service Desk 
integration?

The hp OpenView Storage Area Manager Service Desk integration is a software 
product, which, by means of a full integration with Service Desk, extends the 
management scope of Service Desk to include systems managed by hp OpenView 
Storage Area Manager.

The Service Desk integration for Storage Area Manager extends the existing 
integration between Service Desk and HP OpenView Operations (OVO). 

The following are the features provided by the integration:

■ A utility to create Storage Area Manager specific Configuration Item (CI) 
categories

■ A utility to import Storage Area Manager managed devices as configuration 
items in Service Desk

■ Uses the existing integration tools available with the Service Desk integration 
with OVO [modified to suit Storage Area Manager integration needs] to 
forward Storage Area Manager specific events as incidents to Service Desk

■ Uses the existing integration between OVO and Service Desk for 
acknowledging events in OVO when incidents are closed in Service Desk

The integration requires an OVO management server with the Service Desk 
integration installed and configured. It also requires the Storage Area Manager 
SPI to be installed and configured on the OVO management server in order to 
function correctly as the integration of Storage Area Manager with Service Desk 
is tightly coupled with the Storage Area Manager SPI.
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2Installation

■ Installation prerequisites, page 24

■ Installing the hp OpenView storage area manager Service Desk integration, 
page 30

■ Installed file locations, page 33
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Installation prerequisites
This section lists the prerequisites for the installation of:

■ hp OpenView storage area manager Service Desk 4.0 integration

■ hp OpenView storage area manager Service Desk 4.5 integration

Note:  Uninstall the previous version of hp OpenView SAM Service Desk Integration 
before installing this version. 

The hp OpenView storage area manager Service Desk 4.0 integration will get 
installed only if the system has Service Desk 4.0 server installed, while hp 
OpenView storage area manager Service Desk 4.5 integration will get installed 
only if the system has Service Desk 4.5 client installed. To avoid problems during 
the installation of the integration, it is essential that you read this section, and any 
other documents recommended in the section, before you start the installation 
process. 

Hardware requirements
■ For a detailed list of hardware requirements on the Service Desk Server/Client 

Systems and on the OVO System, refer to the HP OpenView Service Desk 
4.0/4.5 Installation Guides and hp OpenView Service Desk supported 
platforms list, which is included with the Service Desk 4.0/4.5 products. The 
additional disk space requirements are shown in the table below.

Table 1:  Disk Space Requirements for Service Desk 4.0

Machine OS Installation Installation 
Runtime 

Files Total

Service Desk 
Server

Windows NT 
Server, Windows 
2000 Advanced 
Server 

10 MB 1 MB 11 MB

OpenView 
Operations 
(OVO) Server

Windows 

HP-UX

Sun Solaris

1 MB - 1 MB
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Note:  No additional memory (RAM) is required on the target system for installation of 
these integrations.

Software requirements
For a detailed list of software requirements for the Service Desk server/client and 
the OVO server, refer to the HP OpenView Service Desk 4.0/4.5 Installation 
Guides

Table 2:  Disk space requirements for Service Desk 4.5

Machine OS Installation Installation 
Runtime 

Files Total

Service Desk 
Client

Microsoft Windows 
98 SE, Microsoft 
Windows NT 4.0 
Workstation, 
Microsoft Windows 
2000 Professional, 
Windows 2000 
Terminal Services 
(W2k Advanced 
Server only), 
Microsoft Windows 
XP Professional

5 MB 1 MB 6 MB

OpenView 
Operations 
(OVO) 
Server

Windows

HP-UX

Sun Solaris

1 MB - 1 MB
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The following table lists the versions of Storage Area Manager, Service Desk 
server and OpenView Operations management server supported by these 
integrations. 
 

 

Table 3:  Storage Area Manager Supported Versions

Operating System Storage Area Manager Version

Windows 2000 03.20.xx

Table 4:  Service Desk Supported Versions

Operating System Service Desk Version

Windows 4.0 with Service Pack 4 

4.5 with Service Pack 16

HP-UX 4.5 with Service Pack 16

Sun Solaris 4.5 with Service Pack 16

Table 5:  OVO Supported Versions

Operating System OVO Version

HP-UX 11.00

HP-UX 11.11

A.07.xx, and A.08.1x

HP-UX 11.23 IA A.08.2x

Sun Solaris 8

Sun Solaris 9

A.07.xx and A.08.1x

Windows 2000 A.07.2x, and A.07.50

Windows 2003 
(32-bit)

A.07.21, and A.07.50
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Software prerequisites for Service Desk 4.0 

On the Service Desk server

■ HP OpenView Service Desk 4.0 VantagePoint Operation Integration (Service 
Desk Server part) should be installed and configured correctly. For details, 
refer to the HP OpenView Service Desk 4.0 Installation Guide and HP 
OpenView Service Desk 4.0 VantagePoint Operation Integration 
Administrator’s Guide.

■ If the Service Desk server is running Microsoft Windows NT, the Microsoft 
ODBC text driver must be installed on the Service Desk server prior to the 
installation of the integration.

■ Oracle 8.1.7/9i client with Network Components must be installed and 
configured correctly. This is required to import the OVO managed nodes as 
Configuration Items on Service Desk from OVO UNIX Servers.

Note:  The Microsoft ODBC text driver is part of the Microsoft Data Access Components 
(MDAC) package. The MDAC can be obtained freely from the following location: 
http://www.microsoft.com/data/download2.htm 

On the OVO management server

■ HP OpenView Service Desk 4.0 VantagePoint Operation Integration (OVO 
Server part) should be installed and configured correctly.

Service Desk Agent should be installed and configured correctly. For details, refer 
to the HP OpenView Service Desk 4.0 VantagePoint Operation Integration 
Administrator’s Guide. To install Service Desk Event Communicator and Service 
Desk Agent on Sun Solaris 2.8 and HP-UX 11.11 platforms, you need to modify 
the installation script named as install.sh after installing HPOVSD depot.

■ Follow the steps below to modify the install.sh script:

— On the HP-UX 11.11 system:

a. Edit the file /opt/OV/SD/vantagepoint/install.sh

b. Look for the line:

 _VERSION=‘uname -r‘ 

and comment the line.
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c. Add the following line after the commented line:

 _VERSION=B.11.00

d. Save and close the file

— On the Solaris 2.8 system:

a. Edit the file /opt/OV/SD/vantagepoint/install.sh

b. Look for the line:

_VERSION=‘uname -r‘ 

and comment the line

c. Add the following line after the commented line:

_VERSION=5.7

d. Save and close the file

■ hp OpenView Smart Plug-In for hp OpenView Storage Area Manager should 
be installed and configured correctly. For details, refer to the hp OpenView 
Operations Smart Plug-In for hp OpenView storage area manager 
administrator’s reference.

Software prerequisites for Service Desk 4.5:

On the Service Desk client

■ Oracle 8.1.7/9i client with Network Components must be installed and 
configured correctly. This is required to import the OVO managed nodes as 
Configuration Items on Service Desk from OVO UNIX Servers.

■ If the Service Desk client is running Microsoft Windows NT, the Microsoft 
ODBC text driver must be installed on the Service Desk client prior to the 
installation of the integration.
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On the OVO management server

■ HP OpenView Service Desk 4.5 Event and OpenView Operations Integration 
should be installed and configured correctly.

■ Service Desk Agent should be installed and configured correctly. For details, 
refer to the HP OpenView Service Desk 4.5 OpenView Operations Integration 
Administrator's Guide.

■ hp OpenView Smart Plug-In for hp OpenView Storage Area Manager should 
be installed and configured correctly. For details refer to the hp OpenView 
Operations Smart Plug-In for hp OpenView storage area manager 
administrator's reference.

Note:  For both Service Desk 4.0 and 4.5, you must install hp OpenView Smart Plug-In 
for OpenView Storage Area Manager (OVSAMSPI) on OVO management servers for 
proper operation. The supported version of OVSAMSPI on OVO Windows is 
03.11.00, 03.21.00 and 03.21.21. The supported version of OVSAMSPI on OVO 
UNIX is 03.10.00, 03.20.00, 03.20.10 and 03.20.30.
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Installing the hp OpenView storage area manager Service 
Desk integration

The hp OpenView storage area manager Service Desk integrations can be installed 
using the InstallShield setup program. To install the hp OpenView SAM Service 
Desk 4.0 integration on the Service Desk server and hp OpenView SAM Service 
Desk 4.5 integration on Service Desk client, use the setup program as described in 
the following steps:

1. Run setup.exe to begin the installation.

2. The InstallShield wizard shows one of the following options to select the 
installation package feature depending on the Service Desk product installed 
on the system.

a. The following window will get displayed if the Service Desk 4.0 server is 
present on the system:

Figure 3:  Storage Area Manager Integration for Service Desk 4.0 window
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b. The following window will get displayed if the Service Desk 4.5 client is 
present on the system:

Figure 4:  Storage Area Manager Integration for Service Desk 4.5 window
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c. The following window will get displayed if the Service Desk 4.0 server 
and Service Desk 4.5 client both are present on the system: 

Figure 5:  Storage Area Manager Integration for Service Desk 4.0 and Service Desk 
4.5 window

Note:  hp OpenView Service Desk 4.0 integration and hp OpenView Service Desk 4.5 
integration can co-exist on a same system.

3. Choose the integration/s that you want to install by checking the box provided 
next to the option and click Next. 

4. Follow the online instructions to complete the installation.
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Installed file locations
The table below shows the directories and files that are created during the 
installation of Storage Area Manager Service Desk integration.

I

Table 6:  Installed File Locations for hp OpenView SAM Service Desk 4.0 integration

File Type Location

Executable 
programs/DLLs/jar 
files

<Service Desk Installed location>\OpenView SAM 
Integration\bin

Service Desk 
Extractor 
Configuration file

<Service Desk Installed 
location>\data_exchange\config

Documentation <Service Desk Installed location>\OpenView SAM 
Integration\doc

Table 7:  Installed File Locations for hp OpenView SAM Service Desk 4.5 integration

File Type Location

Executable 
program, DLL and 
associated 
configuration files

<Service Desk Client Installed location>\OpenView 
SAM Integration\bin

Service Desk 
Extractor 
Configuration file

<Service Desk Client Installed 
location>\data_exchange\config

Service Desk ACES 
XML file

<Service Desk Client Installed 
location>\data_exchange\xml

Documentation <Service Desk Installed location>\OpenView SAM 
Integration\doc
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3Configuration for Service 
Desk 4.0

■ Creating hp OpenView storage area manager specific CI categories, page 36

■ Creating template for import mapping, page 38

■ Import mapping settings for importing hp OpenView storage area manager 
devices, page 41

■ Creating data exchange task, page 49

■ Configuration required for forwarding events from OVO, page 52

■ Acknowledging the OVO events from Service Desk, page 63
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Creating hp OpenView storage area manager specific CI 
categories 

The first step in the configuration process is to create Storage Area Manager 
specific Configuration Item (CI) categories.

Follow the steps below to create Storage Area Manager specific CI categories in 
Service Desk:

1. Set environment variable SD_JRE_PATH as a system variable to the location 
where the Java Runtime Environment (JRE) is present. This environment 
variable should point to the directory where the java executable is stored. The 
SD_JRE_PATH environment variable is set through the Control Panel: 
System Properties -> Advanced -> Environment Variables.

Note:  JRE will get installed when you install Service Desk on the system. You can also 
install and use your own JRE.

2. Close the HP OpenView Service Desk client interface if it is open.

3. Open the command prompt by typing cmd from the Windows Run dialog.

4. At the command prompt, change directory to the path where the Storage Area 
Manager Service Desk integration is installed. 

5. Type CreateCICategories <Server> <Username> <Password> and press 
Enter

where 

Server: Hostname where Service Desk Application Server is running

Username: Service Desk Application Server user name

Password: Service Desk Application Server user password

Caution:  Service Desk user should have the privilege of System Administrator 
to create the CI categories. If you do not know the user name and password, 
contact the System Administrator.
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6. The following messages are displayed:

Creation of categories is in progress. Please wait....

Successfully created the categories.

7. Note that there should not be any error messages on your console.
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Creating template for import mapping 
The next step in the configuration process is to create a template for import 
mapping. This template is used for importing Storage Area Manager specific 
devices.

To create a template for import mapping:

1. Open the Service Desk client.

2. From the Tools menu, click System -> Data -> Templates -> Configuration 
Item. The Template window opens.

Figure 6:  Template Window

3. Right-click anywhere in the Template window and select New Template from 
the menu that appears. The New Template dialog box opens. 
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Figure 7:  New Template Dialog Box

4. Type OVSAM_DEVICES in the Name text box and choose CI as a Template 
category as shown above.

5. Double-click on the Category field in the New Template Dialog box shown in 
Figure 8 to open the Category window.

Figure 8:  Default Category Location Window

6. Choose Hardware/Storage as shown in the figure above and click OK. This 
is the default CI category for all imported configuration items.

7. Double-click on the Status box in the New Template dialog box shown in 
Figure 9 to open the Status field window.
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Figure 9:  Status Field Window

8. Choose Installed in the Status box as shown above and click OK.

9. Similarly double-click on the Unique field in the New Template dialog box 
shown in Figure 10 to open the Unique field window.

Figure 10:  Unique Field Window

10. Check the Unique check box as shown in the figure above and click OK. 

11. Click OK on the New Template dialog box shown in Figure 11 to store the 
newly created template for import mapping.
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Import mapping settings for importing hp OpenView storage 
area manager devices

The next step in the configuration process is to create import mapping required for 
importing Storage Area Manager devices. 

1. Open the Service Desk client.

2. From the Tools menu, click System -> Data -> Data Exchange -> Import 
Mapping. The Import Mapping window opens.

Figure 11:  Import Mapping Window

3. Right-click anywhere in the Import Mapping window. Select New Import 
Mapping from the menu that appears. The New Import Mapping dialog box 
opens.
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Figure 12:  New Import Mapping Dialog Box

4. Provide the name ovsam_import in the Name field of the Import Mapping 
dialog box for the import mapping to identify which external application it is 
used for. 

5. Click the Add button in the Item Mapping pane. The External Class Nodes 
dialog box opens.

Figure 13:  Mapping External Class with Configuration Item
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6. Type nodes in the Name field, choose Configuration Item from the Item list 
box and choose OVSAM_DEVICES template from the available templates 
before clicking OK. 

7. The available attributes for OVSAM_DEVICES template will get displayed in 
the Field Mapping pane of the Import Mapping window. The New Import 
Mapping dialog box with available attributes in the Field Mapping pane is 
shown in the figure below.

Figure 14:  New Import Mapping Dialog Box with Available Attributes for Field 
Mapping

8. Double-click on the Name 1 field in the Field Mapping pane. The Field 
Mapping - Name 1 window opens. 
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Figure 15:  Field Mapping for Name1

9. Type DEVICE_NAME in the External Property field as shown above and 
click OK.

10. Double-click on the Name 2 field in the Field Mapping pane. The Field 
Mapping-Name2 window opens.

Figure 16:  Field Mapping for Name 2

11. Type MSNAME_ID in the External Property field. Check This field is used 
for key binding check box as shown above and click OK.

12. Double-click on the IP Address field in the Field Mapping pane. The Field 
Mapping-IP Address window opens. Type IP_ADDRESS in the External 
Property field and click OK.

13. Double-click on the Serial Number field in the Field Mapping pane. The 
Field Mapping - Serial Number window opens. Type SERIAL_NUMBER in 
the External Property field and click OK.

14. Double-click on the Search Code field in the Field Mapping pane. The Field 
Mapping - Search Code window opens. Type SEARCH_CODE in the 
External Property field and click OK.
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15. Double-click on the Categor&y field in the Field Mapping pane. The Field 
Mapping -Categor&y window opens.

Figure 17:  Field Mapping for Categor&y

16. Type CATEGORY in the External Property field and click on the Values>> 
button to get the Value Mapping pane as shown below.

Figure 18:  Value Mapping for Categor&y
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17. In the Value Mapping pane, enter Storage in the text box provided to the left 
of the Maps to and choose Hardware/Storage/Storage Device in the text box 
provided to the right of the Maps to. Click the Add To List button to add this 
entry into the Value Mapping pane.

18. In the Value Mapping pane, enter Interconnect in the text box provided to the 
left of the Maps to and choose Hardware/Storage/Interconnect Device in 
the text box provided to the right of the Maps to. Click the Add To List button 
to add this entry into the Value Mapping pane.

19. In the Value Mapping pane, enter NAS in the text box provided to the left of 
the Maps to and choose Hardware/Storage/NAS Device in the text box 
provided to the right of the Maps to. Click the Add To List button to add this 
entry into the Value Mapping pane.

20. In the Value Mapping pane, enter Bridge in the text box provided to the left of 
the Maps to and choose Hardware/Storage/Bridge in the text box provided 
to the right of the Maps to. Click the Add To List button to add this entry into 
the Value Mapping pane.

21. In the Value Mapping pane, enter Host in the text box provided to the left of 
the Maps to and choose Hardware/System/Server in the text box provided to 
the right of the Maps to. Click the Add To List button to add this entry into 
the Value Mapping pane.
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After adding all the entries, the Value Mapping pane should display all the entries 
as shown in the figure below.

Figure 19:  Final Value Mapping for Categor&y
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22. You should get the window shown in the figure below after finishing all the 
field mappings and the value mappings required for importing. Click OK to 
store the newly created import mapping.

Figure 20:  Import Mapping for Importing hp OpenView storage area manager 
Devices
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Creating data exchange task
The next step in the configuration process is to create the Data Exchange Task. 
This task would be used for importing Storage Area Manager devices as CI’s in 
Service Desk.

To create a Data Exchange task:

1. Open the Service Desk client.

2. From the Tools menu, click System -> Data -> Data Exchange -> Data 
Exchange Task. The Data Exchange Task window opens.

Figure 21:  Data Exchange Task Window

3. Right-click anywhere in the Data Exchange Task window and select New 
Data Exchange Task from the menu that appears. The New Data Exchange 
Task window opens
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Figure 22:  New Data Exchange Task Window

4. In the New Data Exchange Task Window:

a. Select the check boxes Export data from a storage device and Import data 
into Service Desk database. 

b. Choose SamCIExtractor.ini in the Export mapping field from the 
available drop-down list.

c. Enter SamCIExtractor.xml in the Exchange file field.

d. Choose ovsam_import in the Import mapping field from the available 
drop-down list.

e. Enter the Service Desk account name and password.
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The figure below shows the New Data Exchange Task after filling the values.

Figure 23:  Data Exchange Task Window for Importing hp OpenView storage area 
manager Devices 

5. Click OK to store the newly created data exchange task.
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Configuration required for forwarding events from OVO
For forwarding events from OVO to Service Desk, configuration task needs to be 
performed on Service Desk server as well as OVO server.

The following configurations need to be done on the OVO server:

■ Modify the configurable extractor file

The following configurations need to be done on the Service Desk server:

■ Create import mappings for forwarding the events

Modify the configurable extractor file

For OVO on Unix:
The file ovsam_event_unix.ini is a configurable extractor used to extract 
information from VantagePoint. It can be found in the 
/opt/OV/OVSAMSPI/sdevent folder. You will need to update the ACCOUNT 
and SERVER entries in the configuration file, as a minimum requirement. A copy 
of the ovsam_event_unix.ini file follows:

[SD_EVENT]

SERVER=sd_application_server

ACCOUNT=VPU_server/password

LOGFILE=ovsam_event.log

ERROR_LOG_FILE=ovsam_event_error.log

PORT=30980

CLASSNAME=incident

MAPPING=ovsam_event_unix

MODUS=insert

LANGUAGE=GB

Note:  Refer to chapter 4 “VP UNIX and Service Desk Configuration” in the HP 
OpenView Service Desk 4.0 VantagePoint Operation Integration Administrator’s Guide 
for details.
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For OVO on Windows:
Modify the configurable extractor ovsam_event_windows.ini. The default 
location is: %OvInstallDir%\bin\OVSAMSPI. You will need to update the 
ACCOUNT and SERVER entries, as a minimum requirement. A copy of 
ovsam_event_windows.ini file follows: 

[SD_EVENT]

SERVER        = sd_application_server 

ACCOUNT       = VPW_server/password

LOGFILE       = ovsam_event.log

ERROR_LOGFILE = ovsam_event_error.log

PORT          = 30980

CLASSNAME     = incident

MAPPING       = ovsam_event_windows

MODUS         = insert

LANGUAGE      = GB

Note:  Refer to chapter 3 “VPO for Windows and Service Desk Configuration” in the 
HP OpenView Service Desk 4.0 VantagePoint Operation Integration Administrator's 
Guide for details.

Create import mappings for forwarding the events
Import mappings are required to be done on the Service Desk server for 
forwarding events from OVO Windows and Unix servers. Most of the fields 
(internal attributes and external properties) which are required to be mapped are 
similar on both the platforms (Windows and Unix).

For OVO on UNIX:
1. From the Tools menu of Service Desk client, click System --> Data 

Exchange --> Import Mapping. The Import Mapping window opens as 
shown in Figure 11.

2. Right-click anywhere on the Import Mapping window and select New Import 
Mapping. The New Import Mapping window opens as shown in Figure 12.

3. Enter ovsam_event_unix in the Name field and click the Add button to open 
the New External Class window.
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Figure 24:  New External Class Window

4. In the New External Class window, type incident in the Name field and select 
Incident in the Item field’s list box. In the Template field, select 
external_event from the available templates.

5. Click OK to display the available attributes for external_event template in the 
Field Mapping pane as shown in the figure below:

Figure 25:  New Import Mapping Window for Forwarding the Event from OVO Unix 
to Service Desk
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6. The next step is to associate the Internal Attributes with the External Property. 
Double-click on the entry which has a field value of Classification. The Field 
Mapping - Classification window opens.

Figure 26:  Field Mapping - Classification Window

7. Type classification in the External Property field and click OK.

8. Repeat the same procedure for associating the Internal Attribute to the 
External Property for the fields shown in the table below.

9. Double-click on the entry which has a field value of Configuration Item. The 
Field Mapping - Configuration Item window opens. 

Table 8:  Fields Required to be Mapped for Forwarding Events from OVO Unix

Internal Attribute External Property

Categor&y category

Status status

Solution solution

Impact impact

Information information

Description description
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Figure 27:  Field Mapping - Configuration Item Window

10. Type ci in the External Property field and choose Name 2 in the A Reference 
to Item field and click OK. 

11. Double-click on the entry which has a field value of Source ID. The Field 
Mapping-Source ID window opens.

Figure 28:  Field Mapping - Source ID Window

12. Type event_id in the External Property field and check This field is used for 
key binding check box and click OK.

13. Double-click on the entry which has a field value of Priority. The Field 
Mapping -Priority window opens.
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Figure 29:  Field Mapping - Priority Window

14. Type priority in the External Property field and click on the Values>> button 
to get the Value Mapping pane as shown below

Figure 30:  Value Mapping for Priority field
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15. In the Value Mapping pane, enter normal in the text box provided to the left 
of the Maps to and choose None from the drop-down list provided to the right 
of the Maps to. Click the Add To List button. Repeat this procedure for the 
entries shown in the table below.

16. Click OK in the Field Mapping - Priority window to store the field mapping 
created for the Priority field and click OK in the New Import Mapping 
window shown in Figure 25 to store the newly created import mapping.

For OVO on Windows:
1. From the Tools menu of Service Desk client, click System -> Data Exchange 

-> Import Mapping. The Import Mapping window opens as shown in 
Figure 11.

2. Right-click anywhere on the Import Mapping window and select New Import 
Mapping. The New Import Mapping window opens as shown in Figure 12.

3. Enter ovsam_event_windows in the Name field and click the Add button to 
open the New External Class window as shown in Figure 24.

4. In the New External Class window, type incident in the Name field and select 
Incident in the Item field’s list box. In the Template field, select 
external_event from the available templates.

Table 9:  Value Mapping Required for Priority Field

Value for External 
Property Value for Internal Attribute 

warning Low

minor Medium 

major High

critical Top
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5. Click OK to display the available attributes for external_event template in the 
Field Mapping pane as shown in the figure below:

Figure 31:  New Import Mapping Window for Forwarding Events from OVO 
Windows to Service Desk

6. The next step is to associate the Internal Attributes with the External Property. 
Double-click on the entry which has a field value of Classification. The Field 
Mapping - Classification window opens as shown in Figure 26.

7. Type classification in the External Property field and click OK.
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8. Repeat the same procedure for associating the Internal Attribute to the 
External Property for the fields shown in the table below.

9. Double-click on the entry which has a field value of Configuration Item. The 
Field Mapping-Configuration Item window opens as shown in Figure 27.

10. Type ci in the External Property field and choose Name 2 in the A Reference 
to Item field and click OK. 

11. Double-click on the entry which has a field value of Source ID. The Field 
Mapping-Source ID window opens as shown in Figure 28.

12. Type event_id in the External Property field and check This field is used for 
key binding check box and click OK.

13. Double-click on the entry which has a field value of Impact. The Field 
Mapping - Impact window opens

Figure 32:  Field Mapping for Impact

Table 10:  Fields Required to be Mapped for Forwarding Events from OVO Windows

Internal Attribute External Property

Categor&y category

Status status

Solution solution

Priority priority

Information information

Description description
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14. Type impact in the External Property field and click on the Values>> button 
to get the Value Mapping pane as shown below

Figure 33:  Value Mapping for Impact Field
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15. In the Value Mapping pane, enter 32 in the text box provided to the left of the 
Maps to and choose Top (Site/Organization affected) from the drop-down 
list provided to the right of the Maps to. Click Add To List button. Repeat this 
procedure for the entries shown in the table below.

16. Click OK in the Field Mapping - Impact window to store the field mapping 
created for the Impact field and click OK in the New Import Mapping window 
shown in Figure 31 to store the newly created import mapping.

Note:  Refer to the HP OpenView Service Desk 4.0 Data Exchange Administrator's 
Guide for creating the import mappings.

Table 11:  Value Mapping Required for Impact Field

Value for External Property Value for Internal Attribute

16 High (Department affected) 

8 Medium (Group/unit affected)

4 Low (1 person affected)

2 None
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Acknowledging the OVO events from Service Desk
The following configuration tasks need to be performed on the OVO Windows 
server for acknowledging the events on OVO Windows server when a 
corresponding incident gets closed on the Service Desk server.

The Storage Area Manager SPI forwards the Storage Area Manager related events 
from OVO (Windows and Unix) to Service Desk. To acknowledge these 
forwarded events on OVO Windows when they are closed on Service Desk side, 
follow the steps below:

1. Open the file named as Vpw-Sd.vbs available in %OV_PATH%\bin\tools 
directory.

2. Replace all references of root/HewlettPackard/OpenView/VantagePoint in 
the file with root/HewlettPackard/OpenView/Data.

3. Save and close the file.

Note:  No manual configuration is required for acknowledging the events on the OVO 
Unix server.
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4Configuration for Service 
Desk 4.5

■ Importing hp OpenView storage area manager settings, page 66

■ Select geographical location for importing OpenView SAM devices, page 70

■ Forwarding events from OVO, page 72
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Importing hp OpenView storage area manager settings
The first step in the configuration process is to import the following settings into 
Service Desk:

■ Storage Area Manager CI Categories

■ Template for importing Storage Area Manager devices

■ Import mapping for Storage Area Manager devices

■ Data exchange task for importing Storage Area Manager devices

■ Import mappings required for forwarding events from OVO Unix and 
Windows

Follow the steps below to import the above settings:

1. Open the Service Desk client.

2. On the Tools menu, click System to open the Administrator console.

3. In the Administrator console select File -> Aces -> Aces Import Wizard.

4. On the first page of the ACES Import Wizard click Next.

Figure 34:  ACES Import Wizard
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5. Select the ACES XML file. To select ACES XML file do following:

Figure 35:  Import file selection

a. Click Add.

b. Browse to the data_exchange\xml directory and select the 
ovsam_aces.xml file.

c. Specify the name of the log file as ovsam_aces.log.

d. Clear the Overwrite existing items checkbox.

e. Click Next.

6. Click Start import. The status of the import is indicated in the progress bar. 
During the import process you will be shown information regarding the status 
of the import. During the import process the Next and Back buttons are 
disabled. At the end of the import process you are automatically sent to the 
next page of the wizard. 
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Figure 36:  Import progress screen

7. View the Import log by clicking on View logfile. There should not be any 
error messages in log file.
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Figure 37:  Import completed

8. Select the option Close the Wizard and then Finish.
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Select geographical location for importing OpenView SAM 
devices

Location is the mandatory field for the template which is used for importing the 
storage area manager devices. To select the location follow the steps below:

1. Open the Service Desk Client.

2. On the Tools menu, click System to open the Administrator console.

3. In the left pane of Administrator console, click Data -> Template -> 
Configuration Item to open the available templates window in the right pane 
as shown below:

Figure 38:  Template Window
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4. Double click on OVSAM_DEVICES template to display 
OVSAM_DEVICES - Template window as shown below:

Figure 39:  OVSAM_DEVICES template

5. Double click on location field to display the location window:

Figure 40:  Location selection window

6. Select the appropriate geographical location by clicking the browse button 
located at right hand side and click OK.

7. Save and close the OVSAM_DEVICES template window.
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Forwarding events from OVO
The following configurations need to be done on the OVO server to forward the 
events from OVO to Service Desk:

■ Modify the configurable extractor file on OVO Unix server

■ Modify the configurable extractor file on OVO Windows server

Modify the configurable extractor file on OVO Unix server
The file ovsam_event_unix.ini is a configurable extractor used to extract 
information from OpenView operations. It can be found in the 
/opt/OV/OVSAMSPI/sdevent folder. You will need to update the ACCOUNT 
and SERVER entries in the configuration file, as a minimum requirement. A copy 
of the ovsam_event_unix.ini file follows:

[SD_EVENT]

SERVER=sd_application_server

ACCOUNT=OVU_server/password

LOGFILE=ovsam_event.log

ERROR_LOG_FILE=ovsam_event_error.log

PORT=30980

CLASSNAME=incident

MAPPING=ovsam_event_unix

MODUS=insert

LANGUAGE=GB

Note:  Refer to chapter 4 “OVO UNIX and Service Desk Configuration” in the HP 
OpenView Service Desk 4.5 OpenView Operations Integration Administrator's Guide 
for details.
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Modify the configurable extractor file on OVO Windows server
Modify the configurable extractor ovsam_event_windows.ini. The default 
location is: %OvInstallDir%\bin\OVSAMSPI. You will need to update the 
ACCOUNT and SERVER entries, as a minimum requirement. A copy of 
ovsam_event_windows.ini file follows:

[SD_EVENT]

SERVER = sd_application_server

ACCOUNT = OVW_server/password

LOGFILE = ovsam_event.log

ERROR_LOGFILE = ovsam_event_error.log

PORT = 30980

CLASSNAME = incident

MAPPING = ovsam_event_windows

MODUS = insert

LANGUAGE = GB

Note:  Refer to chapter 3 “OVO for Windows and Service Desk Configuration” in the 
HP OpenView Service Desk 4.5 OpenView Operations Integration Administrator's 
Guide for details.



Configuration for Service Desk 4.5

74 Storage Area Manager Service Desk Integration administrator’s reference



75Storage Area Manager Service Desk Integration administrator’s reference

5Using

■ Importing OVO managed nodes as CIs, page 76

■ Importing hp OpenView storage area manager devices as CIs, page 77
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Importing OVO managed nodes as CIs
Storage Area Manager Service Desk integration uses the Service Desk 
VantagePoint/ OpenView Operations integration to import OVO managed nodes. 
The following sections describe the procedure to import OVO managed nodes 
from UNIX and Windows OVO servers.

Import OVO managed nodes from UNIX server

For Service Desk 4.0

Refer to chapter 4 “VP UNIX and Service Desk Configuration” section 
“Importing Nodes Into Service Desk” in the HP OpenView Service Desk 4.0 
VantagePoint Operation Integration Administrator's Guide for details.

For Service Desk 4.5

Refer to chapter 4 “OVO UNIX and Service Desk Configuration” section 
“Importing Nodes Into Service Desk” in the HP OpenView Service Desk 4.5 
OpenView Operations Integration Administrator's Guide for details.

Import OVO managed nodes from Windows server

For Service Desk 4.0

Refer to chapter 4 “VPO for Windows and Service Desk Configuration” section 
“Importing Nodes Into Service Desk” in the HP OpenView Service Desk 4.0 
VantagePoint Operation Integration Administrator's Guide for details.

Note:  When importing OVO managed nodes from Windows OVO 7.X server ensure 
that Service Desk Extractor INI file vpwindowsci.ini should use the namespace 
root\HewlettPackard\OpenView\Data.

For Service Desk 4.5

Refer to chapter 3 “OVO for Windows and Service Desk Configuration” section 
“Importing Nodes Into Service Desk” in the HP OpenView Service Desk 4.5 
OpenView Operations Integration Administrator's Guide for details.
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Importing hp OpenView storage area manager devices as CIs

Creating device information file
The SamCIExtractor program, which is included with the Storage Area Manager 
Service Desk integration, queries the Storage Area Manager bridge for collecting 
information regarding the devices managed by the Storage Area Manager. It 
collects the information such as Device Name, IP Address (if available) etc. and 
stores it in the samrecords.txt file. This file is given as an input to the 
import/export process.

Note:  For details on how to configure the Storage Area Manager bridge, refer to 
chapter 7, “Configuring the Bridge,” in the hp OpenView storage area manager 
administrator’s guide.

Follow the steps below to create the samrecords.txt file:

1. Open the command prompt by typing cmd from the Windows Run dialog.

2. At the command prompt, change the directory to the path where the Storage 
Area Manager Service Desk integration is installed. 

3. Type SamCIExtractor at the command prompt and press Enter.

a. At the prompt:

Enter the HP OpenView SAM Bridge hostname:

Type the <HP OpenView SAM Bridge hostname> and press Enter.

b. At the prompt:

Enter the HP OpenView SAM Bridge port:

Type the <HP OpenView SAM Bridge Port> and press Enter.
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c. At the prompt:

Enter the HP OpenView SAM username:

Type the <HP OpenView SAM username> and press Enter.

d. At the prompt:

Enter the HP OpenView SAM password:

Type the <HP OpenView SAM password> and press Enter.

e. At the prompt:

Re-enter password:

Confirm the <HP OpenView SAM password> and press Enter.

4. The following messages are displayed:

SamCIExtractor Starting to query <Server> at port <Port>....

Successfully created samrecords.txt file

5. Note that there should not be any error messages on your console.

Start data exchange task to import hp OpenView storage area 
manager devices as CIs

1. Open the Service Desk client.

2. From the Tools menu of Service Desk client, click System -> System Panel 
-> General Settings.
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In Service Desk version 4.0 the General Settings window would appear as shown 
below: 

Figure 41:  General Settings Window
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In Service Desk version 4.5 the General Settings window would appear as shown 
below: 

Figure 42:  General Settings Window

3. Uncheck the Unique Search Code For CI check box as shown in the figures 
above and click OK.

Note:  After importing Storage Area Manager devices, set the Unique Search Code For 
CI check box to the original settings.

4. From the Tools menu of Service Desk client, click System -> Data -> Data 
Exchange -> Data Exchange Task. The Available Tasks window opens.
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5. From the Available Tasks window, open the SamCIExtractor task by 
double-clicking it.
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6. Type the password into the Password field and start the export/import process 
by pressing the Start button. The Import Progress window appears as shown 
below:

Figure 43:  Import Progress Window

7. There should not be any errors or warning messages in the Import Progress 
window, as shown in the figure above.

8. Close the Import Progress window and the Data Exchange dialog box and see 
the added configuration items under appropriate CI categories. The figure 
below shows a sample of Storage Area Manager devices imported as 
configuration items.
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Figure 44:  Sample Imported Configuration Items for Storage Devices

9. Restart the Service Desk Service from Start -> Programs -> hp OpenView 
service desk 4.0 -> Tools -> Restart hp OpenView service desk Server 
service.

Note:  Restarting Service Desk Service is required to map the events forwarded to the 
Service Desk with the imported configuration items. 
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6Troubleshooting

■ Events do not get forwarded/acknowledged from/on OVO, page 86

■ Mapping of the forwarded events with CIs On Service Desk, page 87

■ Log files for forwarded events from OVO to Service Desk, page 88
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Events do not get forwarded/acknowledged from/on OVO
Symptom Cause/Solution 

 I get a message 
"Successfully 
forwarded the event 
from OVO 
(Windows) to 
Service Desk" in 
the Annotation field 
of the OVO 
Windows server, 
but I am not able to 
see the 
corresponding 
event as incident on 
the Service Desk 
server.

Check to ensure that the ovsam_event_windows.ini file 
is modified correctly. Refer to page 53 for details.

Restart the OVO agent on the OVO management server 
by issuing opcagt -kill and opcagt -start commands.

Verify that OVO Windows systems have the permissions 
to access the HTTP services offered by Service Desk. 
To verify do this:                         

a. Open Server Settings Editor on Service Desk 
server. 

b. On the Server Configuration window, select the 
HTTP tab. 

c. Ensure that the IP address of the OVO Windows 
server is present in Accept IP addresses field.

I get a message 
"Failed to forward 
the event from OVO 
(Unix) to SD 
(Service Desk)" in 
the Annotation field 
of the OVO Unix 
server.

Verify that OVO Unix systems have the permissions to 
access the HTTP services offered by Service Desk: 

a. Open Server Settings Editor on Service Desk 
server. 

b. On the Server Configuration window, select the 
HTTP tab.

c. Ensure that the IP address of the OVO Unix 
server is present in Accept IP addresses field.

Events do not get 
forwarded/acknowl
edged from/on 
OVO UNIX

Verify that the users storage_op and Service Desk in 
OVO have access to the events belonging to 
OpenView-SAM message group and OpenView SAM 
related node groups.
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Mapping of the forwarded events with CIs On Service Desk
Symptom Cause/Solution 

I see the incident on 
the Service Desk 
without any entry in 
the Configuration 
Item field.

Check to ensure that the import mappings 
ovsam_event_windows and ovsam_event_unix are set 
correctly. Refer to page 53 for details.

Restart the Service Desk Service from Start -> 
Programs -> hp OpenView service desk 4.0 -> Tools 
-> Restart hp OpenView service desk Server service. 

Note:  If the configuration item corresponding to the 
incident is not present in the Service Desk, the CI field would 
be blank.
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Log files for forwarded events from OVO to Service Desk
The following log files are available for trouble shooting purpose:

1. sd_event.log and ovsam_event.log: These log files contain information about 
the forwarded events.

2. sd_event_error.log and ovsam_event_error.log: These log files contain 
information about errors that occurred while forwarding the events.

The locations of the above log files on OVO UNIX and Windows servers for 
Service Desk 4.0 and 4.5 are given in the table below:

Table 12:  Log file locations for forwarded events from OVO to Service Desk

File Location

Service Desk 4.0 integrated with OVO UNIX

sd_event.log /opt/OV/SD/bin/

sd_event_error.log /opt/OV/SD/bin/

ovsam_event.log /opt/OV/SD/bin/

ovsam_event_error.log /opt/OV/SD/bin/

Service Desk 4.0 integrated with OVO Windows

sd_event.log %OvInstallDir%bin\OVSAMSPI\

sd_event_error.log %OvInstallDir%bin\OVSAMSPI\

ovsam_event.log %OvInstallDir%bin\OVSAMSPI\

ovsam_event_error.log %OvInstallDir%bin\OVSAMSPI\

Service Desk 4.5 integrated with OVO UNIX

sd_event.log /opt/OV/sd/ovo/log/

sd_event_error.log /opt/OV/sd/ovo/log/

ovsam_event.log /opt/OV/sd/event/bin/

ovsam_event_error.log /opt/OV/sd/event/bin/

Service Desk 4.5 integrated with OVO Windows

sd_event.log %SD_OVWHOME%log\

sd_event_error.log %SD_OVWHOME%log\

ovsam_event.log %OvInstallDir%bin\OVSAMSPI\

ovsam_event_error.log %OvInstallDir%bin\OVSAMSPI\
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7Uninstalling

■ Uninstalling the hp OpenView storage area manager Service Desk integration, 
page 90
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Uninstalling the hp OpenView storage area manager Service 
Desk integration

This section describes how to uninstall the following integrations from the system:

■ hp OpenView Storage Area Manager Service Desk 4.0 integration 

■ hp OpenView Storage Area Manager Service Desk 4.5 integration 

To uninstall follow the steps below:

1. Select Add/Remove from the Windows Control Panel.

2. Select the entry hp OpenView SAM Service Desk Integration (03.20.30) 
from the list and click Remove.

Note:  As there is only one entry in the Add/Remove Programs window for the above 
two integrations, you cannot remove these integrations separately. If you have installed 
only one integration on the system, then that will get removed after uninstallation. If you 
have installed two integrations on the system then both of them will get removed after 
uninstallation.

This will remove the programs, DLLs, zip/jar files, configuration files, documents 
and Data Source Names (DSNs) created using Microsoft ODBC text driver for the 
installed integration/s. 

hp OpenView storage area manager Service Desk Integration does not remove the 
GUI components automatically during the uninstallation of the product. The GUI 
components should be removed manually in the following order:     

■ hp OpenView storage area manager specific CI categories.

■ Configuration Item template OVSAM_DEVICES.

■ Import    mappings   ovsam_import, ovsam_event_unix and 
ovsam_event_windows.

■ Data Exchange task created for importing Storage Area Manager devices as 
CIs in Service Desk.
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